All Articles News
Roland TR-8S Timing Issue?
Rounik Sethi on Mon, March 19th | 3 comments
There's often small bugs with even the most polished music making hardware. In this video a Roland TR-8S has timing issues when five faders are moved at once! Maybe a firmware update can fix it...
GOOD NEWS: Roland have released a firmware update (1.03) for the AIRA TR-8S which fixes the timing and trigger output issues. Read more here: https://ask.audio/articles/roland-releases-tr8s-103-update-fixes-tempo-sync-issue-new-improvements

Definitely the big news from Roland this month was the announcement of the all new TR-8S that allows for custom sample playback and adds more intuitive (and welcomed) live and production workflows. Whlie the TR-8S Rhythm Performer isn't officially in the shops yet (and we haven't quite got hands-on with a unit either), it looks like there might be a timing issue related to when five or mode faders are moved simultaneously.

We haven't been able to test this out as we don't have a unit to hand, but when we watched sunshine_jones' Instagram video via MatrixSynth it clearly appears to be affecting his TR-8S.

I'd like to add that we expect Roland will be able to address this bug in a firmware update. So, there's no need to be too concerned yet.

UPDATE: Multiple users of TR-8S running 1.0.1 and 1.0.2 are reporting the same issue. In a nutshel, moving four faders is fine, five makes strange things happen to the timing... and six faders causes craziness.

The user above is running TR-8S firmware 1.02. As well as the moving five faders for audio stumbles issue, he also experienced auxiliary output trigger inconsistencies too. Go to the 2nd and 3rd videos above to see this in action.

Roland TR-8S Rhythm Performer top

Roland TR-8S Rhythm Performer.

At this stage it's quite possible a firmware update could fix these obscure issues. The important thing is to let Roland know it exists. And if you have a Roland TR-8S to hand, do test out whether you experience timing issues and drop us a comment here. 

AUXILIARY TRIGGER WEIRDNESS

There's a second issue being reported about which the same user talks about and shows in the 2nd and 3rd videos above: "In the second clip of this set I demonstrate that the dedicated trigger out works perfectly. No problems.
In the last clip I have assigned outputs 1-4 to be triggers, and then assigned tracks 2-5 to operate as triggers (output set to aux 1-4)

"Theoretically then, whatever is programmed on track 2 should come out as a pattern of triggers from output 1.
As you can see this is inconsistent and unreliable. Again, I don't know if this is firmware or hardware, but I have my toes crossed that this is something that a firmware update will set straight.

"The trigger out works great, but there's something still not quite right about the triggers which come out of the assignable outputs. Could be the length of the trigger. Or possibly the voltage. I haven't measured the output so I don't know.  

"I've communicated with Roland about this, and while I doubt they'll take me up on my offer to help, I am positive their engineers are capable and will solve these hassles fast. I'm posting this to be a part of of the general dialog about pluses and minuses and issues as well as excitement around the TR-8S. It's a really lovely machine and I've got faith that these details will soon be sorted."

GOOD NEWS: Roland have released a firmware update (1.03) for the AIRA TR-8S which fixes the timing and trigger output issues. Read more here: https://ask.audio/articles/roland-releases-tr8s-103-update-fixes-tempo-sync-issue-new-improvements

 

[Via: MatrixSynth]

Price: $699 USD

Availability: March 2018

WebRoland.com

Web: https://www.instagram.com/p/BgewiRNDsOo/ 

Comments (3)

You must be logged in to comment. Login Now

  • Maarten
    Tested this on my unit and experiencing the same issue.
    • 8 months ago
    • By: Maarten
    Reply
  • Tim
    Earnestly tried on my unit but its showing no issues, thankfully.
    • 8 months ago
    • By: Tim
    Reply
  • Adamoliver
    Mine has the timing issue, seems to only be a problem when I pull 5 faders down when I tested it earlier.
    • 8 months ago
    • By: Adamoliver
    Reply
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: