• Shelley-Hamby
    Posts: 6
    Joined: Feb 8th, 2021
    Garageband input and output glitch need help
    Hi, I intermittently run into 2 problems with GarageBand. 1. The first is, currently under an audio track (for recording vocals etc.) it will not record sound, no matter what combination of audio/midi preferences I have selected in the GarageBand preferences, or no matter what I have set up for audio input in the system preferences menu, I am using a usb microphone, but I also tested with the internal microphone, and no sound is getting picked up on GarageBand whatsoever, even though in system preferences when I have internal microphone selected it shows the sound levels being picked up when I go to speak, so I know the internal mic is working correctly other than on GarageBand. I generally use a Blue Spark usb microphone, the microphone cable also has an input that I plug my headphones into, and most of the time it works great with GarageBand (The reason the headphones plug into the microphone cable is so that I can hear my vocal audio along with the track audio without any lag in sound). Which overall makes no sense to me, because the sound works fine with Photo Booth video recording, and I can hear my voice through my headphones when I speak into the microphone, so I know the physical microphone is picking up audio. I'm pretty sure this is the first time I've tried to record GarageBand audio since updating to OSX Mojave, so I'm not sure if that has something to do with it or not. 2. The second issue I sometimes have run into, is GarageBand will not output sound through my usb cable for my microphone/headphones even when I have input and output both set to my Blue Spark digital microphone, once again regardless of what I have my audio settings on system preferences set to, as well as the audio midi settings on GarageBand. This issue for whatever reason seemed to happen once every week or two, and the only thing that I could do was not use it for a day, and for whatever reason if I waited a day it would randomly start working again. I have only used GarageBand a few times since updating to OSX Mojave, so I have yet to experience this particular one so I only know for sure that it was happening when I was using High Sierra For both issues in addition to trying every possible audio setting in system preferences, as well as audio/midi input settings in GarageBand, I have also tried restarting GarageBand, and my computer multiple times throughout these issues and nothing changes. I am currently hoping for the 1st issue, that it only takes waiting a day and that recording audio will randomly work again, similarly to how the second issue usually only persisted for a random day at a time, but if anyone has any advice on how to permanently fix these issues it would be greatly appreciated since both problems are fairly frustrating and I cannot seem to find anything helpful covering these issues anywhere else online. Also, I am currently using an early 2013 MacBook Pro Retina display with 2.6gh i5, 8gb ram and 256gb ssd, though when I try to do the same thing on my 2014 MacBook Air 1.4ghz, for whatever reason the same issue seems to happen at the same time, otherwise I'd just airdrop the song and record on my other laptop. Thank you in advance for any help, I am really hoping to be able to have these issues solved once and for all, because other than these intermittent setbacks, I do enjoy the simplicity of GarageBand quite a bit.
  • Joe A
    Posts: 1834
    Joined: Oct 1st, 2013
    Re: Garageband input and output glitch need help
    Hi Shelley - If the issue happens at the same time on two computers, then it must be an issue with the microphone itself. Is there a software utility that comes with the mic that may need to be reset? Or are there any switches on the mic that may have gotten changed..?
  • Shelley-Hamby
    Posts: 6
    Joined: Feb 8th, 2021
    Re: Garageband input and output glitch need help
    I'm re downloading the sound library now, so I have yet to try it and make sure, but I'm pretty sure the screenshot you sent shall have solved my problem. I spent roughly 3 hours on the phone with apple technical support, after deleting everything, redownloading and reinstalling multiple times, as well as actually reinstalling my operating system per their request to no avail, I do believe that what you sent is the ticket to get it to microphone work. But after my all software i checked my mic here and its working properly
You must be logged in to post a reply
Subscribe to receive an email for each new post on this thread. Please login
Recent Threads
Recent Posts
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: