macProVideo.com
Forums
  • Student487456
    Posts: 2
    Joined: Oct 23rd, 2021
    Any way to set the MIDI out channel to be channel 1 by default whenever creating a new instrument track?
    Hi so Ive been using LPX for a long while now and have not ran into this issue til recently. I am using a Nektar LX61+ MIDI keyboard and it used to work fine with LPX til about a month ago where it started to have some issues. My LPX is 10.7 and I am using MacOS Big Sur. So the problem is, before, I used to be able to plug and play the keyboard whenever I launch LPX. But recently, whenever I created a new instrument track, I need to change the MIDI channel out from ALL to 1 in order for me to be able to hear sound output from LPX while playing on my keyboard. So back to my question from the start, is there any way to set the MIDI out channel to be channel 1 by default whenever creating a new instrument track? Thanks in advance!
    Reply
  • Joe A
    Posts: 1732
    Joined: Oct 1st, 2013
    Re: Any way to set the MIDI out channel to be channel 1 by default whenever creating a new instrument track?
    Hi - If this is a new behavior rather than a bug, it must be related to the separate settings for MIDI Port, MIDI Ch In, & MIDI Ch Out that are new in Logic 10.7. But I'm surprised that with MIDI channel settings set to All an Instrument wouldn't play -- the point of having an All setting is so you don't have to worry about channelizing. Even if an Instrument was multitimbral, and within the Instrument plug-in itself there was a setting for reception on only MIDI channel 1, in theory it should still play if the MIDI output channel is set to All. You didn't mention what Instrument(s) you're using -- I'm wondering if this happens for you with all Instruments or just some Instruments? I haven't been able to update to Big Sur & Logic 10.7 yet, so I can't test it here, but based on previous versions of Logic I don't know of any way to change the default MIDI channel setting for a New Instrument, other than maybe to change it in the Default Patch that automatically loads whenever you create a new Instrument track. Assuming that this is now normal behavior, and not specific to particular Instrument(s), and if it's important to you not to have to reset the MIDI channel for each new Instrument, here are a couple of things you could try.. - You could create your own Template (starting point) Project with several Instrument tracks already set to the desired Instruments (or even just blank, but) with the desired MIDI channel settings. If you have to create new Instruments frequently as you work, this would save you some time anyway. My Template has around a dozen Instrument tracks -- some with Instruments loaded, some blank -- ready & waiting. - When you create a new Instrument track it loads the Default Patch; in previous versions of Logic when you load a Patch it loads the MIDI channel setting saved with that Patch. Assuming that's still the case with the new MIDI settings in 10.7, if you create a new Instrument track with the Default Patch and change the desired MIDI setting to Ch1, save it as a new Patch with that setting, and then right-click on that new Patch in the Library and choose "Define as default", maybe when you make a new Instrument track it'll load the new Default Patch with the desired MIDI channel setting. Again, I don't know if this will work with the new MIDI channel settings in 10.7 but I suppose it couldn't hurt to try..
    Reply
  • Student487456
    Posts: 2
    Joined: Oct 23rd, 2021
    Re: Any way to set the MIDI out channel to be channel 1 by default whenever creating a new instrument track?
    Hi Joe, Thanks for responding. To answer your question above about which instruments I cant play when the MIDI channel is set to ALL, Ive tried a few different third parties VSTs and when it is set to all, VSTs such as korg triton or any of the Arturia V collection instruments are able work as per normal but when I try to use VSTs like omnisphere and kontakt (which are my main go tos) I cant get any sound output til I change the MIDI channel output to channel 1. Funnily though, even the stock LPX instruments require me to change the MIDI output to channel 1. This issue has been occurring for me since 10.6. I thought updating to 10.7 will fix this issue for me but sadly the issue still persist. Hope these information will be useful! Thanks for the tips and suggestions
    Reply
  • Joe A
    Posts: 1732
    Joined: Oct 1st, 2013
    Re: Any way to set the MIDI out channel to be channel 1 by default whenever creating a new instrument track?
    I know that Kontakt patches have their own MIDI channel settings internally, so maybe an All setting would be needed there as well? [Still, even if a patch is set to receive MIDI on channel 1 it should play if MIDI is coming in on All channels, which should include channel 1, right?] If this issue was happening for you even with the previous single MIDI channel setting, then I don't know why Logic's internal Instruments wouldn't play with the All setting, I've never run across that. In fact, the only Logic Instrument I use that channelizes at all is the Vintage B3 [different channels for the different manuals), and even that plays with the MIDI channel All setting.
    Reply
You must be logged in to post a reply
Subscribe to receive an email for each new post on this thread. Please login
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: