macProVideo.com
Forums
  • Eddie
    Posts: 18
    Joined: Mar 13th, 2009, 08:57
    Error syncing audio and midi
    Hello all, While I did not find my answer in old threads, the attention given to rose questions made me optimistic about getting help. I purchased 3 logic tutorials, starting with 101. I have a new Macbook pro and am brand new to logic. When I try to use my audio interface( Tascam US122), I almost immediately get an error stating there was a problem syncing the audio and midi. It also gives me a weird sample rate number like 37,000. I downloaded the latest driver from tascam, tried different options in preferences like disabling, software monitoring, selecting tascam 122 as interface, switching down to 16 bit, you name it. I have experimented with software instruments and had fun, but am ready to start audio. Any help resolving this is greatly appreciated. Wish you guys had a certification class coming near Memphis by the way Thanks
    Reply
  • Rounik Admin
    Posts: 8713
    Joined: Dec 16th, 2006, 08:13
    Re: Error syncing audio and midi
    Hi Eddie Welcome to the forums :) I'm not familiar with the US122. In the Applications/Utilities folder you will find an app called Audio MIDI setup. Here you should be able to check the sample rate of your devices. btw, 16bit is the audio bit depth - nothing to do with sample rate. Sample rate for CD audio is 44.1Khz, 48Khz is the SR used on audio for Film... etc. In Logic, the sample rate can be set differently for each project: File > Project Settings > Audio Make sure the SR of Logic matches the SR of the Tascam. Let me know if that helps. Rounik
    Reply
  • Eddie
    Posts: 18
    Joined: Mar 13th, 2009, 08:57
    Re: Error syncing audio and midi
    Thanks for the uncanningly quick response. I was looking for the sample info for the tascam last night, but was looking for it in applications< tascam, not utilities. I will try this today. I knew how to adjust the sample rate(thanks to the great tutorial) but did not know where to find my interface's rate to match it. I will let you know if this does it. Thanks
    Reply
  • Eddie
    Posts: 18
    Joined: Mar 13th, 2009, 08:57
    Re: Error syncing audio and midi
    Did check the sample rate of each. Both are 44.100 kHz. Did just now select tascam 122 as default audio in and out under audio midi setup. Now it doesn't give an error, but only plays a second or two of sound with long gaps inbetween.
    Reply
  • Eddie
    Posts: 18
    Joined: Mar 13th, 2009, 08:57
    Re: Error syncing audio and midi
    Scratch that. Still getting the error message.
    Reply
  • Rounik Admin
    Posts: 8713
    Joined: Dec 16th, 2006, 08:13
    Re: Error syncing audio and midi
    can you describe exactly what you are doing (or Logic is doing ;) when this error message appears, e.g. 5 audio tracks with audio regions, and 2 SI tracks with sculpture and EXS24 trying to playback... or record etc etc... Does this happen in new projects? Does this happen if you use the built-in audio instead of your audio interface: Logic Pro > Preferences > Audio [General] does it still happen? I'd also recommend restarting your Mac and repairing permissions: [url]http://www.macprovideo.com/forum/general/general-general&id=13874[/url] Last question/s... at least for now ;) are you using an 3rd party plug-ins with Logic (not included with Logic studio) What is your I/O Buffer size setting in Logic? Thanks Rounik
    Reply
  • Eddie
    Posts: 18
    Joined: Mar 13th, 2009, 08:57
    Re: Error syncing audio and midi
    Ok here goes. I am simply trying to listen to playback through my audio interface. I have tried this with a few audio tracks and one software track, as well as a new project. In a new project the metronome is intermittent and then it crashes and I get the error message. In a project with tracks, the audio is intermittent. The I/O buffer is 256 and I am not using any third part plug ins. When I use the built in audio, it works fine, except I can't use my live mics. I downloaded the proper driver and didn't have this problem on a pc with cubase, ( I still think logic is better, I'm just not mac or logic savy yet. Feel kinda stuck. I'm probably missing something basic but you got me
    Reply
  • Cajypiu
    Posts: 400
    Joined: Oct 11th, 2006, 09:48
    Re: Error syncing audio and midi
    Hi Eddie, could you tell us what version of Logic, OSX and Quicktime you are running? Have you run the Apple software update from the black apple in the top left corner's menu? Rounik suggested repairing disk permissions... and you do this from a program called Disk Utility found in the utilities folder... which is in turn in the applications folder. This is a good thing to remember if future things go awry. Buffer settings in Logic will also impact the audio MIDI sync error code... but only if you are running too many instruments and effects. Incidentally, what USB port are you using with this device? Cheers, John
    Reply
  • Eddie
    Posts: 18
    Joined: Mar 13th, 2009, 08:57
    Re: Error syncing audio and midi
    Hi John, I will look that info up as soon as I am home shortly, although this might help. It's the new 15" MacBook Pro middle choice. The one that comes with 4G of ram. It is only one week old. I will double check Logic when I get home. I know it's 8. Just dont know if its 8.something. How do I check the ports? Thanks for the reply
    Reply
  • Rounik Admin
    Posts: 8713
    Joined: Dec 16th, 2006, 08:13
    Re: Error syncing audio and midi
    Hi Eddie Make sure it's logic 8.0.2. Go to Software update under the Apple menu. As John says, unplug the USB interface and plug it back in to a different USB port on your mac, restart and hopefully it should be better. :) Rounik
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: