macProVideo.com
Forums
  • Xyzefiy
    Posts: 102
    Joined: Apr 2nd, 2008, 08:09
    Crackling within seconds of Playing
    Sorry to resurrect an old thread, this one to be precise: https://www.macprovideo.com/forum/logic/logic-pro-express&id=18271&sid=#18374 but I never got the problem fixed and resorted to using Garage band to record audio. But with Logic 9 on the cards I'd like to get this fixed. Just to summerize the issue, I get crackling within seconds of playing, but not in playback. I record guitar using an IGUITAR USB hooked directly to my Mac Pro Quad Core. I use an Edirol FA66 Audio Interface. The two are combined as an aggregate instrument so I can use my guitar in Logic. Neither my guitar nor my Audio interface require drivers and recording in Garage Band works fine. Sample rate is 44100, I/O buffer setting and Low Latency mode are off. Different buffer sizes have no effect. I'm out of ideas. If anyone has any clue as to the problem, I'd greatly appreciate any help. Thanks very much. Hope every one's having a good Monday. John
    Reply
  • Rounik Admin
    Posts: 8713
    Joined: Dec 16th, 2006, 08:13
    Re: Crackling within seconds of Pl...
    Hi John, What version of OSX are you running? Your signature says 10.5.3. :) Rounik
    Reply
  • Xyzefiy
    Posts: 102
    Joined: Apr 2nd, 2008, 08:09
    Re: Crackling within seconds of Pl...
    Hey Rounik, My OS is 10.5.8 on both my macbook pro (used for internet) and my Mac quad Core (used for music). The Sig was wrong on both counts ;)
    Reply
  • Rounik Admin
    Posts: 8713
    Joined: Dec 16th, 2006, 08:13
    Re: Crackling within seconds of Pl...
    Hi John, Can I suggest you disconnect your Edirol and try using the iGuitar and the built-in audio interface either as an aggregate device or individually to see if the crackling occurs. Is the crackling sound recorded too? Have you tried to contact the iGuitar manufacturer? It is very strange that GB is fine and Logic not since they both essentially use the same audio engine. Cheers Rounik
    Reply
  • Xyzefiy
    Posts: 102
    Joined: Apr 2nd, 2008, 08:09
    Re: Crackling within seconds of Pl...
    Right, fingers crossed I've solved this, I looked at my aggregate device setup, I had the Edirol and the Iguitar USB, the Edirol was setup as the clock. I added the built in Output and then set that up as the clock. I've just come away from a 45 minute session no crackling. Excellent. Lets see what tomorrow brings. Cheers as ever for the help Rounik mate, btw does Logic 9 still require the use of aggregate devices? I was just wondering cause I can just plug in and play with Garageband.
    Reply
  • Rounik Admin
    Posts: 8713
    Joined: Dec 16th, 2006, 08:13
    Re: Crackling within seconds of Pl...
    Hi John, Must be a great feeling to leave that 'crackling' behind! Glad to know you solved the issue. There are many small improvements in Logic 9 and indeed this is one of them. You can now (like in GB) set the input and output devices independently from within Logic: [img]http://img23.imageshack.us/img23/9080/picture2tm.png[/img] So in theory you shouldn't need to aggregate these devices anymore for them to work the way you need in Logic 9. Best Rounik
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: