macProVideo.com
Forums
  • Kizujoy
    Posts: 100
    Joined: Oct 13th, 2007, 10:21
    External Sound Modules
    Hi Again Every time I open an external midi track the program button in the inspector window is always checked on opening a new track . And it's also put in record mode . When the program mode is check by default it causes my sound module to bring up a different sound . Example : If on channel five on my Fantom is a bass sound and I open a new external midi track , by having the program checked automatically the sound changes . I hope this makes sense . Also unrelated , are you guys based in Montreal ? I'll be in Montreal for a month . If so , I'd love to come by for a visit .
    Reply
  • Peter Schwartz
    Posts: 545
    Joined: Sep 15th, 2007, 06:04
    Re: External Sound Modules
    Where did you create the representation of the Fantom? In AudioMIDI Setup? Or, did you create it directly in the environment in Logic?
    Reply
  • Kizujoy
    Posts: 100
    Joined: Oct 13th, 2007, 10:21
    Re: External Sound Modules
    In the Audio Midi setup .
    Reply
  • Peter Schwartz
    Posts: 545
    Joined: Sep 15th, 2007, 06:04
    Re: External Sound Modules
    That's what I guessed, and that's where the problem lies... When you create an instrument in AMS, you gain the advantage of having that instrument appear in all new Logic projects. The downside is that when the instrument appears in Logic, its program change checkbox is enabled (for your inconvenience). This means that unless you forget to uncheck it before you assign it to a track, bingo, it's going to send an unwanted program change to your keyboard. So you have to remember to do that, or... Delete the device definition in AMS. Then, in Logic, create your own instrument in the environment. When you do this, the program change checkbox won't be enabled by default.
    Reply
  • Kizujoy
    Posts: 100
    Joined: Oct 13th, 2007, 10:21
    Re: External Sound Modules
    Thats great information . Now I know the answer to the question "Why is this happening" . I'm going keep the AMS configuration and just get into the habit of unchecking the program box . Thanks so much .
    Reply
  • Peter Schwartz
    Posts: 545
    Joined: Sep 15th, 2007, 06:04
    Re: External Sound Modules
    You're welcome! BTW, you'll have to do the unchecking the checkboxes dance for each MIDI instrument you've defined. You might want to consider creating a template song in which you've unchecked the program change checkbox(es) in your MIDI instruments. That way you only have to do it once.
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: