macProVideo.com
Forums
  • msandm
    Posts: 72
    Joined: May 26th, 2011, 12:31
    Disk is too slow or System Overload. (-10010)
    Hi, I've been using logic 9 for about 2 years now and every now and then I go through these frequent stages of getting this message: "Disk is too slow or System Overload. (-10010) The Sudden Motion Sensor may have parked the hard drive head, or the disk performance is not sufficient to read or write all audio tracks, or the system was not able to process all data in time" The song I am working on at the moment has 14 tracks and only 4 of them have plug ins on them, 3 of which are just the basic EQ one. I use mainly use outboard effects so there should be barely any load on the computer except for playing back the track. I've frozen the tracks, tried changing the settings in the preferences, buffer size etc. I've scoured the internet for something which could be causing this in my system but can not find an answer. I have even tried turning off this motion sensor function through advice from the apple page but I couldn't do that. I have been to a Mac Store had them run diagnostics checks on my system and they found absolutely nothing wrong. I installed Adobe Audition and Reaper and played the session back in them and there was no issue whatsoever which makes me think it is Logic. I've reinstalled Logic but it stil does it. I've removed third party plug ins. I've changed core amounts. I swear I've done almost everything that has ever been suggested and it has got to breaking point now. Sometimes I wil play through a song for 15 mins or so and then it will start doing it consistently other times it will just do it straight up. Other times it will not do it on a song which has more happening than songs that it does happen. It just makes no sense. I've put the files into a new session and it will work fine and then when I reopen the session it happens again. I'm almost ready to switch to a new program as this is seriously stunting my productivity and enjoyment. Any help would be much appreciated. These are my specs Logic 9.1.8 OS X 10.6.8 Mac Pro 2.8GHZ Quad Core intel Xeoan 4GB Ram 2 hard drives, 1 dedicated audio drive both with around 1.45 TB free space. Lynx Aurora Audio Interface 24 channel and 16. Thanks, Damian
    Reply
  • GaryHiebner
    Posts: 1434
    Joined: May 6th, 2007, 12:54
    Re: Disk is too slow or System Overload. (-10010)
    Hi msandm, What version of Logic 9 are you running? Is it in 32-bit or 64-bit mode. What Mac are you using? And What OS And how much memory is installed on your Mac. Sorry about all the questions, but this will help diagnose the problem.
    Reply
  • msandm
    Posts: 72
    Joined: May 26th, 2011, 12:31
    Re: Re: Disk is too slow or System Overload. (-10010)
    Hi, I have all that info at the bottom of my post and I have tried in both 32 bit and 64 bit and it happens in both modes. Except the Lynx Aurora is 16 channel and 8 channel. Thanks,
    Reply
  • GaryHiebner
    Posts: 1434
    Joined: May 6th, 2007, 12:54
    Re: Disk is too slow or System Overload. (-10010)
    Sorry msandm, I missed the info at the bottom of your message. I don't want to say that this is a bug, but even on my side this system error message comes up quite a bit even when the system isn't overloading. Apple has posted this link on the system overload message, and how to resolve it. [url]http://support.apple.com/kb/TS3834?viewlocale=en_US&locale=en_US[/url] From your setup you have most of this covered. But maybe check your audio preferences and what they've recommend. Maybe one of these changes resolves the issue, such as the Input Buffer. I know from my side I have all these set, and I still occassionally have the system overload message come up. The system overload error message has been a hot topic for the last few years, so I hope Apple addresses this and its corrected in the next version of Logic, whenever that may be. But we all holding thumbs that its really soon! I hope this helps.
    Reply
  • msandm
    Posts: 72
    Joined: May 26th, 2011, 12:31
    Re: Disk is too slow or System Overload. (-10010)
    Hi gary, Thanks for that. Unfortunately I have already been to this page multiple times and tried everything suggested. It is weird it is so inconsistent which makes me think it has to be a bug. It will play fine through a 20 track program with plug ins on half the channels and then come up with the error on a song with ten track and no plug ins. It makes no sense. I really hope they can sort it out. Seems like there are a lot of people with the same issue. Thanks
    Reply
  • GaryHiebner
    Posts: 1434
    Joined: May 6th, 2007, 12:54
    Re: Disk is too slow or System Overload. (-10010)
    Yeah, it definitely seems like a bug that hasn't been resolved. Another workaround is to check the way your plugins are handled on the channelstrips. What you can do is distribute the load of the plugins. So say that you have 8 plugins on one channelstrip. What you can do is route the output of that channelstrip to a bus. Then move 4 of the plugins onto the bus. This should help even out the load of the plugins on the CPU. I know this sounds strange as you are increasing the track count, but I remember reading somewhere that Logic had issues when too many plugins were inserted on a channelstrip. I can't remember where I saw this, but I remember that this was the solution. Hope this helps.
    Reply
  • msandm
    Posts: 72
    Joined: May 26th, 2011, 12:31
    Re: Disk is too slow or System Overload. (-10010)
    Unfortunately usually they are different plug ins on each track like compressors and gates. So I don't think I can really utilize that approach. Also it seems to happen when there are very few plug ins in the session as well as when there are many. Hopefully they can fix this issue somehow. It seems as though it is pretty common from reading around the net. It has become a real issue.
    Reply
  • Christian L
    Posts: 1410
    Joined: Aug 7th, 2006, 11:50
    Re: Re: Re: Re: Re: Disk is too slow or System Overload. (-10010
    I used to get that error a lot on my previous Mac, but thank goodness, I don't get it anymore on my new Mac. Have a look at the System Performance meters at the time you get the error messages (Options > Audio > System Performance). Is it the Audio meters or the Disk I/O that is overloading? Turning off Time Machine backups and other background processes could help, it's definitely worth a try. If you are unable to fix the issue, at least you can turn off "Display audio engine overload message" under Preferences > Audio > General. Logic will stop and you can simply hit the Spacebar to resume playback without getting the annoying warning. Christian
    Reply
  • Funamuy
    Posts: 1
    Joined: Sep 9th, 2013, 06:36
    Re: Disk is too slow or System Overload. (-10010)
    This might not be the same because it's for Logic X, but I used File > Project Managment > Clean Up, and then froze a few tracks and it worked for me. Before I couldn't even play 2 seconds without it freezing up on me. Also, you may want to turn off the power to unused tracks instead of muting them. That saves some processing power as well.
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: