macProVideo.com
Forums
  • MorryNYC
    Posts: 229
    Joined: Nov 7th, 2008, 06:22
    Mod Wheel Not Working as a Mod Wheel
    Hey, Happy Holidays everybody. I have a Novation SL MkII keyboard, and the Mod Wheel does not appear to work. And after a few emails with Novation, and as the problem has unfolded, it lis starting to look like a hardware issue. But I'm finding Novation's tech support very slow. I'm sure partly due to the holidays. So I'm hoping someone will have some insight into this issue so I can help Novation pin-point the trouble. 1. Mod wheel does not work as a mod wheel in ES2, EXS24, or Sculpture, or any of the other instruments. It is available to assign to a specific parameter, such as the rate of LFO 2 in the ES2, but I can't play it as a Mod Wheel. i.e. I can assign it to change the rate of the LFO, but not how much of the signal of the LFO is getting to the router. So, no setting an LFO for vibrato and adding it where needed for expression. 2. Novation tech support asked me to download something called MIDIMonitor and see if any MIDI data is being sent when I move the mod wheel. In MIDIMonitor, if I do not assign the Mod Wheel in AutoMap, I see MIDI data. If I assign the Mod Wheel to a specific parameter in the ES2, I no longer see MIDI data in MIDIMonitor. In Logic's top display, I do not see MIDI data no matter if a parameter is assigned or not. 3. The Mod Wheel is a joy stick, where if you move it up and down, it (supposedly) works as a mod wheel, and back and forth works as pitch bend. The Pitch bend works as expected, no matter what instrument is being used, and it does not have to be assigned in Automap to get it to work. I still get a message from Automat that the control is not assigned, but the pitch bend works as expected, and the MIDI data shows up in Logic's top display. 4. I have a sustain pedal hooked up to the keyboard, and again, though when I move it, Automap tells me it is not assigned, it works as expected in every instrument, and MIDI data shows in both the MIDIMonitor application and in Logic's top display. 5. (This is why I'm beginning to suspect it's a hardware issue, something wrong about the keyboard itself): I gave up on trying to make the mod wheel work, resigning myself to wait for Novation's tech support, and thought I'd experiment with the new synth, the Retro Synth. I just randomly chose a preset, and out of habit more than anything, not expecting anything to happen, I moved the mod wheel up, AND IT WORKED. The preset had the mod wheel set to control an LFO, and moving the mod wheel up added an increasingly intense vibrato as you moved it up, exactly as you'd expect the mod wheel to do. I thought I'd go back and try some of the others, thinking, hey, maybe they work now too. But no. No love. And then, when I went back to the Retro Synth, it had stopped working there also. Now, this is starting to sound like a short somewhere, not a software issue. As I'm not terribly tech minded, can someone who has a little more expertise offer me up an opinion as to what might be going on? Thanks!
    Reply
  • MorryNYC
    Posts: 229
    Joined: Nov 7th, 2008, 06:22
    Re: Mod Wheel Not Working as a Mod Wheel
    Another strange development: On my screen, I have an instance of an ES2 and an instance of the Retro Synth, both instruments open at the same time. On the ES2 I have a router set to affect the pitch of Oscillators 1,2,3 with LFO 1, via the Mod Wheel. If the ES2 is in key focus, nothing happens. But if I click on the Retro Synth window, still playing the ES2, the mod wheel starts to work. I don't change the record status of either of the tracks, the ES2 is the only track set to record. I just click on the window of the open Retro Synth instrument. The second I click back to the ES2, the mod wheel stops working and is stuck at whatever state I left the mod wheel in when the Retro Synth was in focus. Clicking back to the Retro Synth window causes the mod wheel assignment on the ES2 begin to work again. Odd, n'est-ce pas?
    Reply
  • Luvekeo
    Posts: 5
    Joined: Nov 4th, 2007, 06:38
    Re: Mod Wheel Not Working as a Mod Wheel
    I'm having the same issue with my SL MkII and LPX. When you click on a plugin Automap assumes that your trying to tweak that plugin and switches to the Automapped control for that plugin (the light on the keyboard says FX or INST) The problem is that I can't figure out how to keep the mod wheel, pitchbend and expression pedal) working as their traditionally used (MIDI CC#1, PB, and CC#11 respectively)! Under global settings, you have the option to always keep the sustain pedal assigned to CC#64, why not the mod wheel & expression pedal?
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: