macProVideo.com
Forums
  • Xedapaa
    Posts: 2
    Joined: Mar 5th, 2012, 10:07
    Crashing and Plugins
    Hi again - How can I stop my DAW [LogicPro] from freezing and crashing so much when using plugins? I have upgraded to LogicPro X and also upgraded my music MacBookPro 15" (2013 model) to go beyond the minimum requirements for some instrument libraries which are CPU hungry (max i could go to was 8GB RAM)â¦.. and am also using 64bit platform on LogicPro 9 [which is automatic on LogicPro X]. However, my software {Logic] is crashing every few minutes when I use these plugins [the associated samplers including particularly: 'Engine', for Best Service libraries; and 'Kontakt Player 5', paid version, especially when using piano instruments. It has got to the point where my software is almost unusable and I have to force quit and re-open in a 7 hour session for example, over 50x! Now, with the 'Engine' plugin, I can't even record a track before Logic freezes, and the only way possible is to pause a recording, save it, and continue, which isn't really conducive to a good impro! Before I used to get a 'system overload' message; now I just get an instant crash, so its getting worse. It also happens during simple playback. I have tried freezing tracks to reduce the impact on CPU, but to no avail. Its been a true test to my patience levels! :-) Does anyone have any advice on how I can stop this, make the best use of my memory and stop the CPU hungry plugins from crashing my system? Also I'm growing tired of manually saving every time I make a single change in Logic 9 [before it crashes], and when I reopen LogicPro X, I'm never sure which is the latest save - mine, or the autosave. Could this be a software problem/glitch, a setup issue I am missing, or possibly a hardware one? I don't have this problem with internal LogicPro instruments. I would be most appreciative of any advice, given that the libraries I want to use are some of my favs - e.g. Epic World, Forest Kingdom II, Desert Worlds, Galaxy Vintage D piano and more Thanking you in advance :-)
    Reply
  • Rounik Admin
    Posts: 8713
    Joined: Dec 16th, 2006, 08:13
    Re: Crashing and Plugins
    Hi Megs, I see you're running OS X 10.8.5? Have you run the Native Instruments Service centre to check for all the latest updates for Kontakt? I'd also do some house keeping on your Mac: Close all apps, Run Disk Utility and run Repair Disk Permissions on your Mac's hard drive. Do a restart... see how Logic Pro X is doing... Do you have other plug-ins which are causing an issue?
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: