macProVideo.com
Forums
  • Dusan
    Posts: 3
    Joined: Sep 13th, 2014, 09:05
    midi recording no sound
    When I finish recording audio and want to start recording midi, I have to turn off my audio interface (MBox2) first, because keyboard can only be plugged in directly into computer via usb cable. However, when I do that-there is no sound from my keyboard. I change Logic preferences to built-in input and output, but that doesn't help. PLEASE HELP!!
    Reply
  • Christian L
    Posts: 1410
    Joined: Aug 7th, 2006, 11:50
    Re: Re: midi recording no sound
    Hi Dusan and welcome to the forums. You should be able to plug your Mbox 2 and your keyboard at the same time. Although it's recommended to connect the Mbox 2 to a dedicated USB port on your computer, you may be able to use it when connected to a powered USB hub. If you have enough free ports, try to connect both the Mbox and your keyboard directly to your Mac. If it's not working, please give us more information (i.e. what keyboard & computer you're using, are you using a hub, etc.) Thanks!
    Reply
  • Dusan
    Posts: 3
    Joined: Sep 13th, 2014, 09:05
    Re: midi recording no sound
    Thanks Christian. I connect both Mbox2 and keyboard (M-audio Oxygen 61) to my laptop via USB. However Mbox2 requires digidesign input and keyboard requires built-in input. So, when I finish recording audio and want to record midi I have to detach Mbox2 and switch input to built-in to enable keyboard. This is hassle but worst part is that once I do it, it doesn't produce sound. I have to restart computer.
    Reply
  • Dusan
    Posts: 3
    Joined: Sep 13th, 2014, 09:05
    Re: Re: Re: Re: midi recording no sound
    Can somebody please help? This is driving me crazy. I don't use any usb hub. I have two usb ports, to one I connect Mbox2, to the other midi keyboard. It almost never works correctly, there is no sound from the keyboard. I contemplate suicide. I use Mac OS 10.6.8 and Logic 9.0.0. Oxygen 61 keyboard
    Reply
  • GaryHiebner
    Posts: 1434
    Joined: May 6th, 2007, 12:54
    Re: midi recording no sound
    Hi Dusan, Do both USB ports on your Mac work correctly? Try plugging the MBox into each on and see if it recognises the device. Then when you plug your Oxygen MIDI keyboard into your Mac make sure the Mac recognises it. Go to the Audio MIDI Setup (Applications > Utilities). Then go to the Window menu and choose Show MIDI window. See if your MIDI keyboard shows up here. If it doesn't show up click on Rescan MIDI and see if it shows up. I'd also recommend that you get a powered USB hub. This will help as you won't have to unplug and re-plug devices.
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: