macProVideo.com
Forums
  • Jideseo
    Posts: 107
    Joined: May 1st, 2011, 01:01
    Can't find interface since Yosemite
    Dear Macprovideo, I just updated to Yosemite. Now, when I launch Logic, it finds my external drive (where the projects are) but can't find my Focusrite Saffire interface which is daisy chained to that drive. I've tried putting the drive into the trash and then switching it off and on again, but Logic still can't find the interface (which IS switched on BTW). When I look in System Preferences>Sound, the interface is not shown. Do you have any suggestions? Best regards, Tim
    Reply
  • Jideseo
    Posts: 107
    Joined: May 1st, 2011, 01:01
    Re: Can't find interface since Yosemite
    I've also tried switching off EVERYTHING and relaunching, but it was no use. Tim
    Reply
  • Ivandub
    Posts: 3
    Joined: Feb 26th, 2015, 06:56
    Re: Can't find interface since Yosemite
    I've heard of people having all kinds of problems with Yosemite if they update from a previous version of OS X as opposed to doing a clean install and then re-installing your software. The update route can break all sorts of things. It might be necessary to do this (a clean install) to get things working properly again. Make sure to back up anything you don't want to lose first if you go this route. I did do a clean install of Yosemite and am experiencing no problems whatsoever. I have Logic Pro 9 and Logic Pro X running flawlessly on both a MacBook Pro with Retina display and a MacBook Air. Hopefully, you can find another fix to your problem but, if not, a clean install should get everything working again. There is all sorts of info on the web about how to do this...it's pretty painless. Good luck!!
    Reply
  • Jideseo
    Posts: 107
    Joined: May 1st, 2011, 01:01
    Re: Can't find interface since Yosemite
    Thank you for your reply. It looked like a clean install was on the cards but fortunately, a mac tech support guy suggested that we first check out the website of my third party interface (Focusrite Saffire pro 24) for new drivers. I hadn't thought of that, because (unlike with my previous interfaces) the Focusrite had happily used the same drivers through a series of OS updates (Leopard, Snow Leopard, Lion, Mountain Lion). I guess this was an update too far. We went to the Focusrite site and, lo! There were the new Yosemite drivers ready for download! Everything is now working fine. Best regards, Tim
    Reply
  • Ivandub
    Posts: 3
    Joined: Feb 26th, 2015, 06:56
    Re: Re: Can't find interface since Yosemite
    Hi Tim, Glad to hear it was such a simple fix...sure saved you a lot of trouble. I hadn't thought about updating the drivers as the interface I use doesn't require one on a Mac. I have a Focusrite 2i4 USB interface which is recognized by Apple Core Audio when you plug it in. As I mentioned, I did do a clean install with Yosemite and have experienced no problems of any kind. After taking a bit of time to get used to its new look and behaviour, I really like it now. Anyway, happy recording and good luck with your projects. Best regards. Ivan
    Reply
You must be logged in to post a reply
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: