macProVideo.com
Forums
This thread has been flagged as solved.
  • Lynn
    Posts: 39
    Joined: Aug 10th, 2009
    No Monitor
    Recording with Logic 10X. Record is on, I have a signal from the keyboard into Logic, signal is coming into channels. Recording works but can’t hear through monitors. Only headphones. Any ideas? Thanks!
    Reply
  • Joe A
    Posts: 185
    Joined: Oct 1st, 2013
    Re: No Monitor
    There could be any number of reasons for this -- I’d need quite a bit more detail as to your setup & procedure.. - First off, it's helpful if you describe your system as suggested on the Forums Home page ( below the Forums list).. - Do you hear the signal at all times through the headphones? - If so it could be a connection issue, outside of Logic -- computer->(interface)->amp/speakers.. - What are the headphones plugged into? - How are the speakers connected to the computer? - Are you using Logic with an interface or playing through the computer's built-in output? - If there's an interface involved , it may have a software utility that controls monitoring -- what brand/model is it? - When you say you can't hear through the monitors, do you mean at all times only when recording? - If the latter, do you hear the newly-recorded track when playing back after the recording is done? If you're talking about recording AUDIO from the keyboard, the video below (and the ones following it) go through the setup for audio recording -- it's pretty basic, but you might see something in one of the videos (like the input monitoring options for recording, if that turns out to be relevant) that could be helpful.
    Reply
  • Joe A
    Posts: 185
    Joined: Oct 1st, 2013
    Re: No Monitor
    To follow up, if you're recording MIDI rather than audio, an additional question.. - Are you recording MIDI data from the keyboard, or audio -- that is, is the sound coming from an internal virtual instrument, recording MIDI data on an Instrument track, or from the keyboard itself, being piped into Logic and recording an audio waveform on an Audio track? If you are recording MIDI data, there might be more useful information in this course, regarding the hookup and monitoring of audio when working with MIDI instruments..
    Reply
  • Lynn
    Posts: 39
    Joined: Aug 10th, 2009
    Re: No Monitor
    Not MIDI MacBook Sierra 10.12.6 MOTU Lite AVB Using a keyboard, record button is enabled, I have a signal and can hear the song and keyboard through monitors and headphones. Software Monitoring is on, Input 3/4, Stereo Output on. But when I push play, I can hear the other instruments coming through monitors and headphones but not the keyboard anymore. I can still record the keyboards and can hear it back once I’m finished. I didn’t have this problem recording guitars.
    Reply
  • Joe A
    Posts: 185
    Joined: Oct 1st, 2013
    Re: No Monitor
    So, monitoring on an Audio track -- ok, this is most likely to do with the Audio Input Monitoring option (in the Record menu). You said "when I push play, I can hear the other instruments...but not the keyboard anymore..." If you mean that you're playing along with the (already-recorded tracks in the) song before you start recording, and you have Auto Input Monitoring on (as usual), then that's normal -- when you PLAY without recording, a record-armed track will not monitor incoming audio; when you actually begin recording, however, you should hear the incoming audio as you record. (This is traditional behavior, to facilitate punching on the fly) If that's it, you can enable input monitoring by clicking on the "I" button at the bottom of the channel strip (right next to the Rec button) -- start playback after enabling "I". This will insure that the incoming audio is passed through when playing/not recording. Continued..
    Reply
  • Joe A
    Posts: 185
    Joined: Oct 1st, 2013
    Re: No Monitor
    You can enable input monitoring by clicking on the "I" button at the bottom of the channel strip (right next to the Rec button) -- start playback after enabling "I". This will insure that the incoming audio is passed through while playing/not recording -- it's kind of a "rehearsal mode". However, if you're not able to hear the live audio while recording, then it may be something else.. LMK Caveat : I have occasionally seen some glitchiness with audio input monitoring (w Logic 10.4.4) -- If it doesn't work as I just described, you could try toggling Auto Input Monitoring, trying the "I" button with/without the Rec button also enabled, and maybe even toggling the "Input monitoring only for focused track, and record-enabled tracks" Preference (Prefs->Audio->General)..
    Reply
  • Lynn
    Posts: 39
    Joined: Aug 10th, 2009
    Re: No Monitor
    Hi Joe, I enabled input monitoring by clicking on the "I" button at the bottom of the channel strip. That works!! It's interesting, I don't have to do that using when mics but only the keyboard. I also never had to use the "I" in Logic 8. Thank you for all your help. I really appreciate it!! Lynn
    Reply
You must be logged in to post a reply
Subscribe to receive an email for each new post on this thread. Please login
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: