macProVideo.com
Forums
This thread relates to...
GarageBand 101
Absolute Beginner's Guide
by: Vanacoro
More Info
  • Student461197
    Posts: 3
    Joined: May 3rd, 2020
    Flextime splitting rather than stretching in Garageband
    Hi, I'm fairly new to GarageBand but was doing ok and had recorded a first complete real instrument audio track (eight individual tracks in total) but when I started to master the track I noticed my rhythm guitar is fractionally slow to start the chorus. Looking at online tutorials they suggest 'flextime' can be used to just stretch the waveform a little to bring it into time with the other instruments. But when I do this, rather than stretching the audio it moves just a portion of it to where I want it by detaching it from the nearest default audio markers meaning I have a gap in the audio further down the track. Other tutorials suggest dragging the whole audio clip to the correct time but this doesn't work because the clip is quite long and the timing issue is resolved within a bar or so. Any help would be greatly appreciated.
    Reply
  • Joe A
    Posts: 569
    Joined: Oct 1st, 2013
    Re: Flextime splitting rather than stretching in Garageband
    Hi - It sounds like you may be trying to perform the edit in the Track lane rather then in the Editor pane [at the bottom]..? In the Editor pane you'd enable Flex for the Track, select the Region tab, and then.. - Click to create Flex markers at the beginning and end of the section you want to edit [see the screenshots below] - Drag as needed—the audio should be stretched or squeezed only within the range of the Flex Marker you're moving and the Flex markers before & after it [these will function as anchors to protect the rest of the audio from unintentional changes] - There should be automatically-generated Flex markers [dotted lines] already there, and they'll function as anchors, but you can create additional ones [solid lines] wherever needed The video below demonstrates Flex editing—I've linked this thread to that GB course [above]
    Reply
  • Student461197
    Posts: 3
    Joined: May 3rd, 2020
    Re: Flextime splitting rather than stretching in Garageband
    Hi Joe, Thanks for responding and the info you posted. Unfortunately I am trying to carry out the procedure in the editor pane and doing it just like in the video. The difference is that when I drag the flex bar to the left to stretch the wave form it merely pulls the whole of that audio section (up to the next flex bar) to the left and therefore leaving a gap in the audio (the size of however far I pull it to the left), in-between the end of the audio clip which has been adjusted and the next flex marker. I should add that the procedure does seem to work as per the video if I'm squashing the audio down (moving to the right), it's just when I try to stretch it (moving to the left) that it doesn't stretch at all but just detaches. Any help is greatly appreciated.
    Reply
  • Joe A
    Posts: 569
    Joined: Oct 1st, 2013
    Re: Flextime splitting rather than stretching in Garageband
    Ok, a key question—is the audio still being compressed when the gap is created, or is the right edge of the Region simply moving? If it’s the latter, then it’s likely that the cursor is accidentally changing from the Flex tool [ 3 lines w/ downward triangles ] to the Region Trim tool [ left-arrow, right bracket, right arrow ]—that could happen if you’re trying to grab a Flex Marker at the right-most edge of a Region—you might have to create a Flex Marker a little further to the left to successfully grab/drag it, to avoid having the cursor accidentally turn to a Trim tool and adjust the Region’s right boundary, as you seem to be describing..
    Reply
  • Student461197
    Posts: 3
    Joined: May 3rd, 2020
    Re: Flextime splitting rather than stretching in Garageband
    Hi Joe, Thanks for responding again. I've since found out that it's a glitch in the software. Although not common, other people have reported the same issue on Reddit and Apple forums. One suggested that it's so random it might work on some tracks and not others. This led to me to try it on another track and it worked on that one. I then tried pasting the original clip which I'm having problems with into a new project and trying again but alas it still didn't work. As it appears that it's a glitch, I've made do with pasting in a copied clip into the gap that opened in the waveform from shifting it slightly. Hopefully it won't keep happening and it's Sod's law that it did so on the first main arrangement I've made! Thanks again though for your help. Darryl
    Reply
You must be logged in to post a reply
Subscribe to receive an email for each new post on this thread. Please login
Recent Threads
Recent Posts
Feedback
Course Advisor
Don't Know Where To Start?
Ask A Course Advisor
Ask Us!
Copy the link below and paste it into an email, forum, or Facebook to share this with your friends.
Make money when you share our links
Become a macProVideo.com Affiliate!
The current affiliate rate is: 50%
Classes Start Next Week!
Live 8-week Online Certification Classes for: